update to 1.4